Posted on

What are the system/browser requirements for Pixlr apps?

Pixlr Editor, Pixlr Express, and Pixlr-o-matic for the web require the Adobe Flash plug-in. Chances are you already have Flash installed in your browser, but if you don’t you can get it for free here.

Pixlr apps will work on just about any browser, including Chrome, Firefox, Safari, and Internet Explorer. However, be aware that most of the world has moved away from IE6, so if you’re still using it we strongly recommend upgrading to a newer browser.

Pixlr-o-matic is available as an Adobe Air app, which runs Flash apps on your computer (and not in your browser). To use it, you’ll need to download and install Adobe Air, which is a free application.